پیکربندی VLAN در سوئیچ سیسکو

اشتراک گذاری در whatsapp
اشتراک گذاری در telegram
اشتراک گذاری در facebook
اشتراک گذاری در twitter
اشتراک گذاری در linkedin
اشتراک گذاری در email
اشتراک گذاری در print
خدمات IT | مجازی سازی | امنیت شبکه | خدمات سرور | خدمات مایکروسافت | خدمات شبکه | خدمات شبکه و سرور | دوربین مداربسته | طراحی سایت | ITProPlus | پیکربندی VLAN در سوئیچ سیسکو

بنام خدا، سلام عرض می‌کنیم خدمت دوستان عزیز وب سایت ITProPlus، امروز قصد داریم به شما نحوه تنظیمات VLAN در سوییچ سیسکو را به صورت گام به گام آموزش دهیم.

VLAN چیست؟

VLAN مخفف Virtual Local Area Network هست. یعنی شبکه محلی مجازی، هر شبکه محلی برای خودش تنها یک محدوده Broadcast داره که ترافیک محدوده خودش رو در در این محدوده نگه میداره و اگر شما بتونید بصورت مجازی یک شبکه محلی ایجاد کنید در حقیقت تونستید یک محدوده Broadcast یازمانی که در دامین باشیم  Broadcast Domain ایجاد کرده‌ایم و در این حالت ترافیک شبکه به حالت کنترل شده می‌شود.

فرض می‌کنیم که شبکه ما دارای تعدادی سرور و تعدادی کامپیوتر می‌باشیم که 10 کامپیوتر در طبقه اول و 10 کامپیوتر در طبقه دوم می‌باشد می‌خواهیم تنظیماتی انجام دهیم که سیستم‌های طبقه اول و دوم و سرورها همگی در Vlan مجزا باشند.

خدمات IT | مجازی سازی | امنیت شبکه | خدمات سرور | خدمات مایکروسافت | خدمات شبکه | خدمات شبکه و سرور | دوربین مداربسته | طراحی سایت | ITProPlus | پیکربندی VLAN در سوئیچ سیسکو

دلایل طراحی VLAN

  • بالا بردن امنیت شبکه و کنترل دسترسی‌ها
  • بهینه سازی ترافیک شبکه با کنترل پهنای، جهت بالا بردن سرعت شبکه
  • مدیریت آسان برای Policy های سازمان

لایه بندی در سوئیچ سیسکو

لایه Access

در محیط LAN، از طریق لایه Access اجازه دسترسی End Device ها به شبکه، داده می‌شود و در محیط WAN، دسترسی به شبکه از راه دور داده می‌شود. معمولاً در لایه Access از سوئیچ‌های لایه دوم و Access Point ها برای ایجاد دسترسی بین کلاینت ها و سرور استفاده می‌شود.

لایه Distribution

این لایه بین لایه Access و Core قرار دارد و دیتا ارسالی توسط کاربر را از لایه Access به سمت لایه Core هدایت می‌کند. نوع ارتباطات در این لایه از نوع کابلی می‌باشد، بین لایه Access و Core یک مرز ایجاد می‌کند.

لایه Core

به این لایه ستون فقرات شبکه نیز گفته می‌شود. در این لایه دستگاه‌ها با سرعت بسیار قرار می‌گیرند. لایه Core طراحی شده تا جایی که ممکن است عمل سوئیچینگ بسته را با سرعت انجام دهد و بتواند ارتباط بین بخش های مختلف مانند دیتا سنتر، شبکه‌های LAN و WAN و … را برقرار کند. در این لایه باید مسائل دسترسی پذیری (available) و جایگزینی (redundant) مورد توجه ویژه قرار گیرد. در لایه Core ترافیک بسیار زیادی از لایه Distribution به این لایه ارسال می‌شود و این لایه باید توان پردازش سریع این اطلاعات را داشته باشد.

حال با توجه به تعاریف فوق تنظیمات سوئیچ را با در نظر گرفتن لایه‌های سیسکو شروع می‌کنیم.

تنظیمات Core Switch برای VLAN

ابتدا باید پورت‌هایی را به ترانک اختصاص دهیم و سپس تنظیمات را روی آنها قرار دهیم.

  • پورت‌های 1 الی 5 را برای این موضوع در نظر گرفته‌ایم.
  • آنها را در مود ترانک قرار می‌دهیم.
  • استاندارد Dot1q را روی پورت ها تنظیم می‌کنیم.

SW-CORE> enable

SW-CORE# configure terminal

SW-CORE(config)# interface range gig 1/0/1 – 5

SW-CORE(config-if)# switchport mode trunk

SW-CORE(config-if)# switchport trunk encapsulation dot1q

SW-CORE(config-if)# exit

در این لحظه نوبت به تعریف Vlan  در سوئیچ Core می رسد.

SW-CORE(config)# vlan 10

SW-CORE(config-vlan)# name FIRST-FLOOR

SW-CORE(config-vlan)# exit

SW-CORE(config)# vlan 20

SW-CORE(config-vlan)# name SECOND-FLOOR

SW-CORE(config-vlan)# exit

SW-CORE(config)# vlan 50

SW-CORE(config-vlan)# name Servers

SW-CORE(config-vlan)# exit

اختصاص پورت به سرور هایمان اختصاص می‌دهیم.

پورت UPLINK را به روتر وصل می‌کنیم.

یک IP به سوییچ اختصاص می‌دهیم. این IP روی VLAN 1 قرار می‌گیرد که Native VLAN است.

SW-CORE(config)# interface range gig 1/0/10 - 15

SW-CORE(config-if)# switchport mode access

SW-CORE(config-if)# switchport access vlan 50

SW-CORE(config-if)# description DATA SERVER PORT

SW-CORE(config-if)#exit

SW-CORE(config)# interface vlan 1

SW-CORE(config-if)# ip add 192.168.100.1 255.255.255.0

SW-CORE(config-if)#exit

SW-CORE(config)# int gig 1/0/24

SW-CORE(config-if)# switchport trunk allowed vlan 10,20,50

SW-CORE(config-if)# exit

SW-CORE(config)# int gig 1/0/25

SW-CORE(config-if)# switchport trunk allowed vlan 10,20,50

SW-CORE(config-if)# exit

تنظیمات Distribution Switches برای VLAN

SW- Distribution (config)# interface vlan 1

SW- Distribution (config-if)# ip add 192.168.100.2 255.255.255.0

SW- Distribution (config-if)#exit

SW- Distribution (config)# int ra gig 1/0/1 - 10

SW- Distribution (config-if)# switchport mode trunk

SW- Distribution (config-if)# switchport trunk encapsulation dot1q

SW- Distribution (config-if)# switchport trunk allowed vlan 10,20,50

SW- Distribution (config-if)# exit

تنظیمات Access Switches برای VLAN

سوییچ لایه دوم مانند سوئیچ Cisco 2960

سوئیچ طبقه اول

SW-1 (config)# interface range gig 1/0/1 – 20

SW-1config-if)# switchport mode access

SW-1(config-if)# switchport access vlan 10

SW-1(config-if)# exit

SW-1(config)# interface gig 1/0/24

SW-1(config-if)# switchport mode trunk

SW-1(config-if)# exit

سوئیچ طبقه دوم

SW-2 (config)# interface range gig 1/0/1 – 20

SW-2 (config-if)# switchport mode access

SW-2(config-if)# switchport access vlan 20

SW-2(config-if)# exit

SW-2(config)# interface gig 1/0/24

SW-2(config-if)# switchport mode trunk

SW-2(config-if)# exit

سخن آخر: ما در این آموزش سعی کردیم به صورت گام به گام و سریع نحوه تنظیمات VLAN در سوئیچ سیسکو را به شما آموزش دهیم.

در صورت نیاز می‌توانید با کارشناسان گروه متخصصین ITProPlus در تماس باشید تا تنظیمات سوئیچ های سیسکو را به صورت حرفه‌ای برای شما انجام دهند.

موفق و پیروز باشید

مهندس امیررضا فرود

مهندس امیررضا فرود

کارشناسی ارشد فناوری اطلاعات

فهرست مطالب

اشتراک در خبرنامه
ما را در اینستاگرام دنبال کنید
ITProPlus @

فهرست مطالب

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

نیاز به کمک دارید؟

با همکاران ما تماس بگیرید

خدمات IT | مجازی سازی | امنیت شبکه | خدمات سرور | خدمات مایکروسافت | خدمات شبکه | دوربین مداربسته | طراحی سایت | ITProPlus